Cancel
Showing results for 
Search instead for 
Did you mean: 

Versa won't change time zone

Highlighted

Hello.  I have a new Versa and the time zone is stuck on Los Angeles (where I purchased the watch).  I am now in France.  I have my iPhone set to Paris, France, but the app keeps on saying Los Angeles.  Basically, every time I change the time zone, it reverts to Los Angeles after 30 seconds.(tried setting automatically and manually).  I have tried to change the time zone manually and automatically on the Fitbit app and on the phone.  I have also tried reconfiguring the watch with no success.  This is very frustrating.  Any suggestions?

 

Thanks, 

 

Rob

Accepted Solution
25 REPLIES

I am having the same issue. 

Accepted Solution
If I ever figure out how to solve this issue, I'll let you know.  So far, I have received no help from the support staff (via email).
Accepted Solution
0 Votes

Ok.  I may have a solution.  I went to the fitbit site and logged in to my account.  By changing my location on my personal settings and having the computer update the Versa (via its bluetooth connection), the time zone was changed.  Hope this works for you.

Accepted Solution

What @RobMaeda said is correct.  You need to go into your Account Settings and change the time zone from there.  This article explains more about how to change your time zone settings.  This will be what your Versa is connected to, so while you certainly can set up your Versa first, you should make sure that your Time Zone is set properly.

Kristen | USA
Versa, Ace,Flyer, Aria 2, Ionic, Alta HR, Flex 1 (retired), Android app, Windows 10



Need more help? Check out the "Help" site (https://help.fitbit.com/)
Accepted Solution

Just to be clear, I had to do this personal account time zone change from my laptop and not the app on my phone.  When I tried to change the time zone in the app, it did not work.  I think the app needs some work.

Accepted Solution

My time zone in my Fitbit profile is correct but time still displaying in LA. Anymore ideas?

Accepted Solution
0 Votes

@RobMaeda wrote:

Hello.  I have a new Versa and the time zone is stuck on Los Angeles (where I purchased the watch).  I am now in France.  I have my iPhone set to Paris, France, but the app keeps on saying Los Angeles.  Basically, every time I change the time zone, it reverts to Los Angeles after 30 seconds.(tried setting automatically and manually).  I have tried to change the time zone manually and automatically on the Fitbit app and on the phone.  I have also tried reconfiguring the watch with no success.  This is very frustrating.  Any suggestions?

 

Thanks, 

 

Rob


 

Accepted Solution
0 Votes

Same issue here.  I had to log into fitbit web to change time zone manually.  Is so stupid for a new smartwatch 

Accepted Solution

Similar problem here.  Went East from Central Time to Eastern time and Versa updated time okay.  Went West from Eastern Time back to Central time and Versa did not update.

Accepted Solution
All of sudden 2 days later time changed back..guess patience???
Accepted Solution
0 Votes

This is unfortunate.  Fortunately for me mine is still 30-days so I am taking it back and getting a different watch.

Accepted Solution
0 Votes

I got a Versa 2 days ago before an international trip. I set my time zone to San Francisco, California, and then landed in the UK.  But my Versa continued to show the San Francisco time.

 

I fixed this by going into the Fitbit app > Account (looks like an ID card) > Advanced Settings.  There are two check boxes: one for the Automatic Time Zone (which was checked already) and the second one for Automatic Location (which was unchecked).  I checked the box and almost immediately my Versa updated the time.

 

I have to be in a few more countries over the next week.  If the time does not automatically update, I will return my Versa.  It's unacceptable that a smart "watch" cannot perform a basic time zone update when it's synced to a phone that's connected to the Internet. 

 

I hope this tip works for you.

Accepted Solution

My watch finally changed time after restart x2

1.  Take watch off automatic time zone and go into GMT time where u are.

2.  If it doesn't change by resync, restart phone again.

Should work.                             3.  Then next day put it on automatic again

Accepted Solution

Restart phone may take couple times

Accepted Solution
0 Votes
  • I just returned from Tokyo to Washington, DC. Changing settings thru my phone app Did Not work. However; logging in to my profile on Fitbit.com, changing my time zone from Tokyo to Washington, DC there and then syncing thru my phone made the change. Hope this helps!  Beth

 

Accepted Solution
0 Votes
  • Rob,
  • I just returned from Tokyo to Washington, DC. Changing settings thru my phone app Did Not work. However; logging in to my profile on Fitbit.com, changing my time zone from Tokyo to Washington, DC there and then syncing thru my phone made the change. Hope this helps!  Beth

 

Accepted Solution
0 Votes

I just returned from Tokyo and couldn’t get my Versa to update the time.  I made setting changes thru my phone app and that didn’t work. I went into my profile on Fitbit.com and edited my profile there making the change from Tokyo to Eastern US. I went back to my phone and re-synced. The change finally came through to my Versa. Hope that helps.  Beth

Accepted Solution
0 Votes
Finally figured it out. First let your phone adjust to the new time zone then open the Fitbit app and sync the watch. Note you must have Location Services enabled on the phone for it to adjust to local time.
Accepted Solution
0 Votes

Wow what terrible waste on money. It can't simply update the time!  

Accepted Solution
0 Votes